InstallationROR

위키 | 한국 데비안 사용자 모임
이동: 둘러보기, 검색

Ruby on Rails 설치

OS: Debian GNU/Linux Lenny (amd-64)

ruby 설치

   # apt-get install ruby-dev irb libopenssl-ruby

libopenssl-ruby

rails 설치가 끝나고, 프로젝트를 생성후 서버를 동작시킬 때 아래와 같은 오류가 발생함.

   /home/nayoung/lib/ruby/gems/1.8/gems/rails-2.3.2/lib/initializer.rb:269:in `require_f
   rameworks’: no such file to load — net/https (RuntimeError)

해결방법

   apt-get install libopenssl-ruby

.bash_profile (or .bashrc) 수정

   # /home/nayoung/.bashrc
   …
   GEM_HOME=${HOME}/lib/ruby/gems/1.8
   export GEM_HOME
   PATH=${GEM_HOME}/bin:${PATH}
   export PATH
   …

Create gem directory

   $ cd
   $ pwd
   /home/nayoung
   $ mkdir -p /lib/ruby/gems/1.8
   $

RubyGem install

http://rubygems.org/ 에서 최신버전의 RubyGems 를 내려받는다. Rails 1.8.7 버전은 RubyGems 1.3 이상의 버전을 요구한다.

   # tar xvzf rubygems-1.3.2.tgz
   # cd rubygems-1.3.2
   ..** setup 스크립트를 실행전 README 파일을 읽어본다. **
   # ruby setup.rb
   …

Rails install

   $ gem install rails

MySQL Gem install

   ** MySQL library install **
   # apt-get install libmysqlclient15-dev
   …
   $ gem install mysql
   Building native extensions. This could take a while…
   Successfully installed mysql-2.7
   1 gem installed
   $ 

완료

기본적인 프로젝트 생성은

   $ rails <Project_path> --database=<DB:mysql/oracle/postgresql/sqlite2/sqlite3/frontbase/ibm_db>

더 자세한 부분은 RailsGuides 를 읽어보자.

참고

참고: Ruby on Rails, RubyGems Manual